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1 Welcome to My Free Web Site Builder

1.1 Welcome

My Free Website Builder s a complete Web Authoring System that combines web file
management and easy-to-use WYSIWYG (What You See Is What You Get) web page
editing. The software is designed to be extremely easy to use, making it ideal for

non-technical computer users who want to create an attractive, professional-looking
web site without needing to know HTML or web coding.

The software offers

superior

feature rich

powerful

features that make creating webpages a total snap of fingers!

1.2 Introduction

Introduction to My Free Web Site Builder for new users
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FrontPage and Dreamweaver are popular HTML editors for MS Windows.
These programs have become popular because they make web design
extremely easy, even for non-technical people. This software is not an exact
clone of either of these products, but it does contain many of the same easy-

to-use features which makes these programs so popular.Users familiar with
either of these two products will feel right at home using this program.

My Free Web Site Builder is designed to be extremely easy to use. This

makes it ideal for non-technical computer users who want to create an
attractive, professional-looking web site without needing to know HTML or
web coding. My Free Web Site Builder allows you to create web pages as
easily as you would type a word processing document, and then publish
them to your web site just by saving the document. This makes it ideal for

home use, students, marketing professionals, general business use, and so
on. Even though it's designed for the novice web designer, My Free Web Site
Builder is also ideal for experienced web programmers who want to save
time in creating content or web design. Because you can quickly toggle

between the WYSIWYG editing mode and the HTML code mode, just by
changing tabs, My Free Web Site Builder is also ideal for those wishing to
learn HTML programming, as they can easily observe the interaction between
the HTML code and what a user will see in their web browser. The bottom

line is that My Free Web Site Builder is ideal for anyone who wants to quickly
create web pages.

1.3 Features

1) Emphasis on ease-of-use for the non-technical user
2) Robust WYSIWYG editing
3) Integrated web file management
4) Enhanced handling of forms, templates, etc.

5) Extensibility which allows advanced users to build their own extensions to
My Free Web Site Builder with a just a dash of JavaScript. For instance, it will
be very easy to create new "smart widgets" (i.e. a calendar, a date/time
widget, a mail widget, etc.) and integrate them with one click into My Free
Web Site Builder.



Part

II



My Free Web Site Builder Help Manual7

© 2007 MyFreeWebSiteBuilder.com

2 Getting Started

2.1 Scope

This tutorial is designed for beginners, who are new to web page designing with a
WYSIWYG editor. The tutorial provides just enough help so as to get you started with
using MyFreeWebsiteBuilder for your web page design purposes. It is not an
introduction to HTML, XHTML, CSS, etc. coding. Its only aim is to give you a kick start

on how to use MyFreeWebsiteBuilder.

The manual does not even cover all the basic aspects of HTML in detail. Yes, this is a
short tutorial and some basic albeit unimportant things have been left out. You are

encouraged to find out about them yourself. Also the tutorial covers just an introduction
on how to use cascading style sheets with the inbuilt editor, CaScadeS.

For those of you who are more interested in learning about HTML, CSS, etc in detail you

can go to the W3 Consortium website. There you will find detailed information about
various standards maintained by them. You can also do a search on the WWW or refer
to one of the many books available on learning HTML.

In This Tutorial

This tutorial first introduces you to MyFreeWebsiteBuilder's User Interface. This is
followed by a basic formatting section. Next section, tells you how to insert elements
like images, tables, and forms in your document. Then we have small section devoted to

styling your document using CSS. The document concludes with instructions for
publishing your document to a web server.

2.2 User Interface Intro

MyFreeWebsiteBuilder's File Menu contains menu items for all major operations possible
while using it. For full detailed reference read the Menu Reference  page.
MyFreeWebsiteBuilder's tool bar user interface consists of:

    * Composition Toolbar
    * Format Toolbar
    * Tab Browser Toolbar

    * Edit Mode Toolbar
    * Status Toolbar

Composition Toolbar

The Composition Toolbar consists of buttons for the most used major operations. Below
is the a snapshot of the default Composition Toolbar with text below each button
indicating the respective button's function.
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Format Toolbar

The Format Toolbar is a very useful tool while editing web pages with

MyFreeWebsiteBuilder. With the Format Toolbar you can apply paragraph format,
choose a font, change foreground or background colour, increase or decrease size, and
emphasize a block of text. You can also create ordered or unordered lists and justify a
block of text to left, right or centre. To know which button does what just hover your

mouse over the button and a tool tip will appear indicating the function of the button.

Tab Browser Toolbar

MyFreeWebsiteBuilder allows you to simultaneously edit multiple web documents using
different tabs for each opened document. Having multiple tabs gives a cleaner look to

your desktop as it is not cluttered when multiple windows are used for each document.
As a visual indicator a "red floppy icon" icon appears for pages which have been edited
but not saved yet.

Edit Mode Toolbar

The Edit Mode Toolbar indicates the viewing mode which is presently active for the
current document. Available viewing modes are the Normal view, HTML Tags view,
HTML source view and the Preview mode. You can easily change your viewing mode by
simply clicking any of the other three with the mouse.

Status Toolbar

MyFreeWebsiteBuilder's status bar shows the position of the cursor with respect to the

HTML tag hierarchy. You can easily edit/assign the properties of any particular tag in
the status bar just by right clicking and choosing the desired option. Simple left-click of
the mouse on a tag in status bar selects the text surrounded by that tag.

2.3 New Document

You can start a new document by either clicking on the "New" button on the
composition toolbar or by clicking File > New and select "Blank Document" and then
click on "Create". In case you want to edit an existing file use File > Open and choose
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the file you want to edit. For detailed instructions, refer to Starting a New Page section
in the MyFreeWebsiteBuilder Help documentation.

You can also start a new document which is a template instead of a normal html file.
Templates are used to make website management easier as the maintainer will only
need to edit the text for a particular page and not worry about the design as it is
controlled by the template. This tutorial will not go further into creating and using

templates. Further information about templates can be obtained from the Working with
Templates  section of MyFreeWebsiteBuilder Help documentation.

2.4 Basic Formatting

We will use the text given in the next section in the new document to follow the

formatting help in this tutorial. The text will used as a base to learn basic formatting
functions available in MyFreeWebsiteBuilder. Copy the text from the following section
and paste it in your new document.

Tutorial Text

Corbett National Park

Corbett National Park, named in the memory of Jim Corbett, was created in 1938 and

was the first national park to be established in Asia. It is situated in the northern state
of Uttranchal in India. It has an area of 512 sq. km. The combined area of Corbett
National Park, Sonandi Wildlife sanctuary and Reserve Forest areas summing up to 1288
sq. km. constitute a bigger project called Corbett Tiger Reserve.

The most famous animals of Corbett National Park are the Bengal Tiger and the Asiatic
elephant. It is also a home to other animals like etc etc. Situated at the junction of the
Garhwal and Kumaon hill regions it also boasts of the combination of cultures of people
of both regions.

Jim Corbett

Jim Corbett, (1825-19), lived in Kaladhungi. His house has been converted into a
museum by the government as a dedication to his life and times. He was a naturalist,

conservationalist and an avid photographer. Born on 25th July 1875, he grew up in
Kaladhungi and Nanital. After fighting for the British army in the WWI, he came back to
India and settled in Kaladhungi with his sister, Maggie. He was called up several times
by village people and the government to get rid of man-eating tigers and leopards.

Visiting Corbett National Park

General Information

Altitude: 385-1100m above sea level
Annual Rainfall: 1400mm - 2800mm
Temperature range: 4C in winter to 42C in summer.
Open for tourists from 15 November to 15 June.

Getting there:
The head quarters of Corbett Tiger Reserver are at Ramnagar. By road it is connected to
Delhi, Moradabad, Bareilly and Nanital. State transport buses ply from Delhi, Moradabad
and Haldwani to Ramnagar. By rail tourists can reach Ramnagar by taking a train from
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New Delhi.

Formatting the text

The first thing we will take care of are the headings and subheadings. Select the text
"Corbett National Park" at the top of the document and click on the Body Text drop
down menu on the Format Toolbar and select Heading 1. The text will be styled

according to the default Heading Level-1 style. Similarly, select the text "Visiting
Corbett National Park" and make it a level-2 heading.
The second you might want to do is to select entire paragraphs in your text and mark
them paragraph following same procedure for the headings. In the given text this has

already done to make the text more presentable, but otherwise marking paragraphs
separately is a good practice.

You can also style important words or phrases using the bold(B), italic(I), or
underline (U) buttons on the Format Toolbar, as has been done in this line. Several

other options of formatting your text are available from the Format Toolbar or via the
Format menu on the File Menu toolbar. Go ahead and try to use a few options, you will
learn a few trick this way. If you mess up, don't worry, just click "Ctrl+Z" once to undo
your last action. For detailed instructions about all the ways possible to format text for a

web page, see Formatting your Web Pages section in MyFreeWebsiteBuilder Help
documentation.

At this stage, your tutorial text should look similar to this:

 

Corbett National Park

Corbett National Park, named in the memory of Jim Corbett, was created in 1938 and
was the first national park to be established in Asia. It is situated in the northern state

of Uttranchal in India. It has an area of 512 sq. km. The combined area of Corbett
National Park, Sonandi Wildlife sanctuary and Reserve Forest areas summing up to 1288
sq. km. constitute a bigger project called Corbett Tiger Reserve.
The most famous animals of Corbett National Park are the Bengal Tiger and the Asiatic
elephant. It is also a home to other animals like etc etc. Situated at the junction of the

Garhwal and Kumaon hill regions it also boasts of the combination of cultures of people
of both regions.

Jim Corbett

Jim Corbett, (1825-19), lived in Kaladhungi. His house has been converted into a
museum by the government as a dedication to his life and times. He was a naturalist,
conservationalist and an avid photographer. Born on 25th July 1875, he grew up in

Kaladhungi and Nanital. After fighting for the British army in the WWI, he came back to
India and settled in Kaladhungi with his sister, Maggie. He was called up several times
by village people and the government to get rid of man-eating tigers and leopards.

Visiting Corbett National Park

General Information
Altitude: 385-1100m above sea level

Annual Rainfall: 1400mm - 2800mm
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Temperature range: 4C in winter to 42C in summer.
Open for tourists from 15 November to 15 June.
Getting there:

The head quarters of Corbett Tiger Reserver are at Ramnagar. By road it is connected to
Delhi, Moradabad, Bareilly and Nanital. State transport buses ply from Delhi, Moradabad
and Haldwani to Ramnagar. By rail tourists can reach Ramnagar by taking a train from
New Delhi.

2.5 Inserting Images and Tables

Images, tables and forms can be inserted/created in your document using the
Composition Toolbar . Let us insert a table and copy the General Information about
Corbett National Park into it. Click on the "Table" button on the composition toolbar.

And choose the table dimensions to be 5 rows and 2 columns with your mouse. Clicking
on the 5th row in 2nd column will create a default table with those dimensions.

To fill the table with our pre-written text, just cut ("Ctrl+X") the corresponding text and
paste ("Ctrl+V") it in corresponding cell of the table. After you are done, the table

should look like the one below:

Altitude 85-1100m above sea level

Annual Rainfall 1400mm - 2800mm

Temperature range 4C in winter to 42C in summer

Open for tourists 15 November to 15 June

Getting there The head quarters of Corbett Tiger Reserver are at Ramnagar. By
road it is connected to Delhi, Moradabad, Bareilly and Nanital. State
transport buses ply from Delhi, Moradabad and Haldwani to
Ramnagar. By rail tourists can reach Ramnagar by taking a train

from New Delhi.

With the basic table constructed, you can change the table properties by activating the
table i.e. bring the cursor in the table and then click on the "Table" button on the
Composition Toolbar . In the Table Properties dialog, you can set various properties for

the table, cell, row or a column, e.g. background colour for table or cell, table caption,
table alignment, table or column width, etc.

2.6 Advanced Styles

MyFreeWebsiteBuilder allows the users to create or edit cascading style sheets with the
help of its inbuilt style sheet editor named "CaScadeS". CaScadeS has the ability of

using either internal or external style sheets for documents being edited. Details on how
to use CaScadeS are out of scope of this tutorial.

2.7 Publishing

You can publish your documents using MyFreeWebsiteBuilder's built-in the Site
Manager. The visibility of the site manager can be toggled by clicking the F9 button.
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Site manager is being rewritten and hence this part of the tutorial has been postponed
till the new version is released.
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3 Starting A New Page

3.1 Creating A New Page

MyFreeWebsiteBuilder is an HTML (Hypertext Markup Language) editor that allows you
to create and edit web pages. MyFreeWebsiteBuilder is a WYSIWYG  (What You See Is
What You Get) editor, so you can display how your page will look to the reader as you're
creating it. It is not necessary for you to know HTML, since most of the basic HTML

functions are available as commands from the toolbars and menus.

MyFreeWebsiteBuilder also lets you edit the HTML source if you want. To view or edit
the HTML source code, open the View menu, and choose HTML Source, or click the

<HTML> Source tab in the Edit Mode toolbar at the bottom of the MyFreeWebsiteBuilder
window.

To create a web page, use one of the methods described below. Once you've started a

page, you can add and edit text just as you would in a word processor.

To create a new page in MyFreeWebsiteBuilder :
· Click the New button in MyFreeWebsiteBuilder's toolbar.

To start from an HTML file stored on your local drive:
1. Open the Window menu and choose MyFreeWebsiteBuilder. You see the

MyFreeWebsiteBuilder window.
2. Open the File menu and choose Open File. You see the Open HTML File dialog

box.
3. On your local drive, locate the file that you want to edit.
4. Click Open to display the specified file in a MyFreeWebsiteBuilder window.

To edit a web page:
1. Open MyFreeWebsiteBuilder
2. Click on File menu and choose Open Web Location. You will see the Open Web

Location dialog box.

3. Type in the URL of the page to edit (for example, http://www.mozilla.org) and
click Create button. You will see the page displayed in MyFreeWebsiteBuilder.

MyFreeWebsiteBuilder also gives you the option of creating a new document using the
XHTML format. To create an XHTML document, check the option "create an XHTML

document" in the Create New Document or Template dialog box.

Tip: In the MyFreeWebsiteBuilder window you can quickly open the most recent file
you've been working on by opening the File menu, choosing Recent Pages, and then

selecting the file you want from the list.

3.2 Tabs - Editing Multiple Documents

MyFreeWebsiteBuilder allows you to edit multiple documents at the same time. Rather
than to shift from one window to another for editing more than one document,
MyFreeWebsiteBuilder offers the feature of Tabs. More than one document can be

opened at the same time with MyFreeWebsiteBuilder in the same window but in
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different tabs.

Tabs can be opened using either Ctrl+T or by choosing Create in: New Tab in the New

file open dialog. Even with multiple tabs open, each is handled independently. Each
document's state is indicated, i.e. if it is modified and needs saving by a red-floppy icon
on the corresponding tab.

3.3 Saving And Browsing Your New Page

You can save MyFreeWebsiteBuilder documents in HTML or text-only format. Saving a
document in HTML format preserves the document's formatting, such as text styles (for
example, bold or italic), tables, links, and images. Saving a document in text-only
format removes all the

HTML tags but preserves the document's text.

To save a document as an HTML file:
· Open the File menu and choose Save or click the Save button on the

Composition toolbar.
If you haven't already given your page a title, MyFreeWebsiteBuilder prompts
you to do so. MyFreeWebsiteBuilder displays the page title in the browser
window's title bar when you view the page in the browser. The document's page

title also appears in your list of bookmarks if you bookmark the page.
MyFreeWebsiteBuilder then prompts you to enter a filename and specify the
location where you want to save the file. Make sure you preserve the .html
extension in the filename. While saving or editing documents employing XHTML,

the file should have the extension as .xhtml. Files with an extension .html but
having an XHTML DOCTYPE are not considered as xhtml documents.

To change the filename or location of an existing HTML file:
· Choose File > Save As and select a different filename or location.

When you save a page in MyFreeWebsiteBuilder, all parts of the page (the HTML,
images and other files, such as sound files and style sheets), are saved locally on your
hard drive. If you only want to save the HTML part of the page, you must change the

MyFreeWebsiteBuilder preference for saving pages. See MyFreeWebsiteBuilder
Preferences for more information on changing MyFreeWebsiteBuilder's setting for saving
pages.

If an image location is absolute (starts with "http://") and you are connected to the
Internet, you will still see that image in the document in MyFreeWebsiteBuilder and
Navigator. However, if the image location is relative to the page location (starts with
"file:///"), then you won't see the image in the local version of the document.

To save a document as a text-only file:
1. Open the File menu and choose Export to Text.
2. Enter the filename and specify the location where you want to save the file.

Note: Images do not appear in documents saved in the text-only format.

Tip: You can choose Revert from the File menu to retrieve the most recently saved copy
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of the document in which you're working. Keep in mind that your current changes will
be lost.

To view your page in a browser window in order to test your links:
· Open the File menu and choose Browse Page (or click Browse in the Composition

toolbar). If you have not yet saved your document, MyFreeWebsiteBuilder
prompts you to enter a page title, filename, and location. The

MyFreeWebsiteBuilder window remains open behind the new Navigator window.
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4 Formatting Your Web Pages

4.1 Formatting Paragraphs, Headings, and Lists

To apply a format to a paragraph, begin from the MyFreeWebsiteBuilder window:

1. Click to place the insertion point where you want the format to begin, or select
the text you want to format.

2. Choose a paragraph format using the drop-down list in the Format toolbar:
3.
o Body Text : Applies the application default font and style for regular text,

without affecting the spacing before or after the text.

o Paragraph: Inserts a paragraph tag (use this to begin a new paragraph).

The paragraph includes top and bottom margins.
o Heading 1 - Heading 6: Formats the paragraph as a heading. Heading 1

is the highest-level heading, while Heading 6 is the lowest-level heading.
o Address: Can be used for a web page "signature" that indicates the

author of the page and the person to contact for more information, for
example: user@example.com
You might want to include the date and a copyright notice. This format
usually appears at the bottom of the web page under a horizontal line.

Navigator displays the address format in italics.
o Preformat : This is useful for elements such as code examples, column

data, and mail messages that you want displayed in a fixed-width font. In
normal text, most browsers remove extra spaces, tabs, and paragraph
returns. However, text that uses the Preformatted style is displayed with

the white space intact, preserving the layout of the original text.

To format text as a heading:

1. Click to place the insertion point anywhere within the text that you want to
format.

2. Using the drop-down list in the Format toolbar, choose the level of heading you
want, from 1 (largest) to 6 (smallest). Choose "Heading 1" for your main

heading, "Heading 2" for the next level, and so forth.

To apply a list item format:
1. Click to place the insertion point within the line of text that you want to format.
2. Open the Format menu and choose List.

3. Choose the list style:
4.
o Bulleted: Each item has a bullet (dot) next to it (as in this list).

o Numbered: Items are numbered.

o Term and Definition : These two styles work together, creating a

glossary-style appearance. Use the Term tag for the word being defined,
and the Definition tag for the definition. The Term text appears flush left,
and the Definition text appears indented.

Tip: You can quickly apply a list style to a block of text by selecting the text and

clicking the Numbered List  or Bulleted List  buttons on the Format toolbar.
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To change the style of bullets or numbers:

1. Click to place the insertion point within the text of the list item you want to

change, or select one or more items in the list if you want to apply a new style
to the entire list.

2. Open the Format menu and choose List Properties.
3. Select a bullet or number style from the drop-down list. For numbered lists, you

can specify a starting number. For bulleted lists, you can change the bullet style.

Tip: You can also double-click on a bullet or number in a list to display the List
Properties dialog box.

To align a paragraph or text in your page, for example, centering or aligning to the left
or right:

1. Click to place the insertion point within the paragraph or line of text you want to

align.
2. Open the Format menu and choose Align; then choose an alignment option.

Note: You can also use the Format toolbar to align text.

4.2 Working With Lists

To end a list and continue typing body text:

· Click to place the insertion point at the end of the last list item and press Enter

(Return on Mac OS) twice to end the list.

To change one or more list items to body text:

1. Click to place the insertion point within the list item, or select the list items.
2. In a numbered list, click the numbered list button (or in a bulleted list, click the

bulleted list button) in the Format toolbar.

To position indented text below a list item:

1. Click to place the insertion point within the list item.
2. Press Shift-Enter to create the hanging indent.
3. Type the text you want to indent.
4. Press Shift-Enter to create another indented paragraph, or press Return to create

the next list item.

Tip: You can increase or decrease the indentation of list items by clicking anywhere in a
list item and then clicking the Indent or Outdent button on the Format toolbar.

Alternatively, click anywhere in a list item and press Tab to indent one level. Press
Shift+Tab to outdent one level.

To merge two adjacent lists:

1. Select the two lists that you want to merge. Be sure to select all of the elements
in both lists. Note that any text in between the two lists will also become part of
the merged list.
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2. Click the bulleted or numbered list button in the Format toolbar to merge the
lists.

4.3 Changing Text Color, Style, and Font

To change the style, color, or font of selected text:

1. Select the text you want to format.

2. Open the Format menu and choose one of the following:
3.
o Font: Use this to choose a font. If you prefer to use fonts specified by the

reader's browser, select Variable Width or Fixed Width.

Note: Not all fonts installed on your computer appear. Instead of
specifying a font that may not be available to all who view your web page,
it's generally best to select one of the fonts provided in the menu since
these fonts work on every computer. For example, the fonts Helvetica,
Arial, Times, and Courier generally look the same when viewed on

different computers. If you select a different font, it may not look the
same when viewed using a different computer.

o Size: Use this to choose a relative font size or select an option to increase

or decrease text size (relative to the surrounding text).

o Text Style: Use this to select a style, such as italic, bold, or underline, or

to apply a structured style, for example, Code.
o Text Color: Use this to choose a color from the color picker. If you are

familiar with HTML hexadecimal color codes, you can type a specific code
or you can just type a color name (for example, "blue"). You'll find a

handy color code converter here.

To change the background color of the page:

1. Click anywhere in the page.
2. Click the background color block in the Format toolbar.
3. Choose a background color from the Block Background Color dialog box.
4. Click OK.

Tip: To quickly change the color of text to the color last used, select the text, then
press Shift and click on the text color block in the Format toolbar. This is useful when
you want to use one color for separate lines of text.

You can also use an image as a background.

4.4 Removing or Discontinuing Text Styles

To remove all text styles (bold, italic, and so on) from selected text:

1. Select the text.
2. Open the Format menu and choose Remove All Text Styles.
3. Continue typing.
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To continue typing text with all text styles removed:

1. Place the insertion point where you want to discontinue the text styles.

2. Open the Format menu and choose Discontinue Text Styles.
3. Continue typing.

4.5 Finding and Replacing Text

To find text in the page you're currently working on:

1. Click to place the insertion point where you want to begin your search.
2. Open the Edit menu and choose Find and Replace. You see the Find and Replace

dialog box.
3. Type the text you want to locate in the "Find what" field. To narrow the search,

check one or more of the following options:
o Match upper/lower case: Use this to specify whether the search is for

case-sensitive text.

o Wrap around : Use this to search to the end of the page and then start

again from the top or bottom, depending on whether you are searching
forward or backwards.

o Search backwards: Use this to search back from the insertion point to

the beginning of the page.
4. Click Find Next to begin searching. When MyFreeWebsiteBuilder locates the first

occurrence of the text, click Find Next to search for the next occurrence.
5. Click Close when you are done.

To find and replace text in the page you're currently working on:

1. Click to place the insertion point where you want to begin your search.
2. Open the Edit menu and choose Find and Replace. You see the Find and Replace

dialog box.
3. Type the text you want to find and then type the replacement text.
4. To narrow the search, check one or more of the following options:

o Match upper/lower case: Use this to specify whether the search is for

case-sensitive text. If you don't select this option, the search will find
matching text in both upper and lower case.

o Wrap around : Use this to search to the end of the page and then start

again from the top.
o Search backwards: Use this to search from the end to the beginning of

the page.
5. Click Find Next to search for the next occurrence. MyFreeWebsiteBuilder selects

the next occurrence of the text.
6. Click Replace to replace the selected text with the replacement text. Click

Replace and Find to replace the selected text and find the next occurrence. Click
Replace All to replace every occurrence in the document with the replacement
text.

7. Click Close when you are done.
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4.6 Inserting Horizontal Lines

Horizontal lines are typically used to separate different sections of a document visually.

To insert a horizontal line (also called a rule) in your page, begin from the
MyFreeWebsiteBuilder window:

1. Click to place the insertion point where you want the line to appear.

2. Open the Insert menu and choose Horizontal Line.

4.7 Setting Horizontal Line Properties

You can customize a line's height, length, width, alignment, and shading.

1. Double-click the line to display the Horizontal Line Properties dialog box.

2. Edit any of these properties:
o Width: Enter the width and then choose "% of window" or "pixels." If you

specify width as a percentage, the line's width changes whenever the
MyFreeWebsiteBuilder window's or browser window's width changes.

o Height: Type a number for the line's height (in pixels).

o 3-D Shading: Select this to add depth to the line by adding a bevel

shading.
o Alignment: Specify where you want to place the line (left, center, or

right).
3. Click Use as Default to use these settings as the default the next time you insert

a horizontal line.
4. To edit the properties of a horizontal line manually, click Advanced Edit. See the

section, Advanced Property Editor , for details.

Tip: You can select "Show All Tags" from the View menu to show all the HTML elements
in yellow boxes. Click any yellow box to select everything within that HTML tag or
element. Double-click any yellow box to display the Advanced Property Editor dialog box
for that HTML tag or element.

4.8 Inserting Special Characters

To insert special characters such as accent marks, copyrights, or currency symbols:

1. Click to place the insertion point where you want the special character to appear.
2. Open the Insert menu and choose Characters and Symbols. You see the Insert

Character dialog box.
3. Select a category of characters.

o If you choose Accent Uppercase or Accent Lowercase, then open the

Letter drop-down list and select the letter you wish to apply an accent to.
(Note: not all letters have accented forms.) Select Common Symbols to

insert special characters such as copyright symbols or fractions.
4. From the Character drop-down list, select the character you want to insert.
5. Click Insert.

You can continue typing in your document (or in a mail compose window) while

you keep this dialog box open, in case you want to use it again.
6. Click Close when you are done inserting special characters.
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4.9 Inserting HTML Elements and Attributes

If you understand how to work with HTML source code, you can insert additional tags,

style attributes, and JavaScript into your page. If you are not sure how to work with
HTML source code, it's best not to change it. To work with HTML code, use one of these
methods:

· Place the insertion point where you want to insert the HTML code, or select the

text you want to edit, and then open the Insert menu and choose HTML. In the
Insert HTML dialog box, enter HTML tags and text, and then click Insert.

· Select an element such as a table, named anchor, image, link, or horizontal line.
Double-click the element to open the associated properties dialog box for that

item. Click Advanced Edit to open the Advanced Property Editor. You can use the
Advanced Property Editor to add HTML attributes, JavaScript, and CSS to objects.

· Open the View menu, and choose HTML Source, or click the <HTML> Source tab
in the Edit Mode toolbar at the bottom of the MyFreeWebsiteBuilder window. (If

you don't see the Edit Mode toolbar, open the View menu and choose Show/Hide;
then make sure the Edit Mode Toolbar is checked.)

4.10 Using the Advanced Property Editor

To add HTML attributes and JavaScript to objects such as tables, images, and horizontal

lines, you can use the Advanced Property Editor.

Note: Unless you clearly understand how to add, delete, or modify HTML attributes and
their associated values, it's best not to do so.

If you are not currently viewing the Advanced Property Editor dialog box, follow these
steps:

1. From the View menu (or the Edit Mode toolbar), choose Show All Tags.

2. Double-click the object that you want to modify to open its Properties dialog box.
3. Click Advanced Edit to open the object's Advanced Property Editor. The Advanced

Property Editor has three tabs, each of which lists the current properties for the
selected object:

o HTML Attributes: Click this tab to view or enter additional HTML

attributes.
o Inline Style: Click this tab to view or enter additional CSS (cascading

style sheet) properties through the <style> attribute. For more
information on using CSS styles in MyFreeWebsiteBuilder, see

MyFreeWebsiteBuilder Preferences .
o JavaScript Events: Click this tab to view or enter JavaScript events.

4. To edit a property or attribute in any of the three lists, select the attribute you
want to edit. You can then edit the attribute's name or value using the editable

Attribute and Value fields at the bottom of the dialog box. To add a new
attribute, type it in the Attribute field at the bottom of the dialog box. The new
attribute is automatically added when you click in the Value field. To remove an
attribute, select it in the list, and click Remove Attribute.

Note: Required attributes are highlighted in the Attribute list.
5. Click OK to apply your changes to the Advanced Property Editor dialog box.
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6. Click OK again to exit the Properties dialog box.

MyFreeWebsiteBuilder automatically places quotation marks around any attribute text.

4.11 Validating the HTML

Before you put your document on a web server(i.e. publish it), it is good practice to first
check the document's HTML formatting so as to make sure that it conforms to web
standards. Documents containing validated HTML are less likely to cause problems when

viewed by different browsers. Just visually checking your web pages in your favourite
web browser doesn't ensure that your document will appear correctly when viewed in
other web browsers.

MyFreeWebsiteBuilder provides a convenient way for you to check that your document
conforms to W3C (World Wide Web Consortium) HTML standards. MyFreeWebsiteBuilder
uses the W3C HTML Validation Service, which checks your document's HTML syntax for
compliance with HTML 4.01 standards. This service also provides information on how to

correct errors.

Note: You must be connected to the Internet to use this feature.

To validate your document's HTML syntax:

1. Open the Tools menu, and choose Validate HTML. If you have unsaved changes,
MyFreeWebsiteBuilder asks you to save them before proceeding.

2. MyFreeWebsiteBuilder will open another window with results for your page

displayed in it after the W3C Validation Service program parses your html file.

4.12 Choosing the Right Editing Mode

Typically, you won't need to change the editing mode from the default (Normal).
However, if you want to work with the document's HTML source code, you may want to
change editing modes.

MyFreeWebsiteBuilder allows you to quickly switch between four editing modes or
views. Each editing mode allows you to continue working on your document, but
displays varying levels of HTML tags (and tag icons).

Before you choose an editing mode:
· Open the View menu, choose Show/Hide, and then make sure there is a

checkmark next to Edit Mode Toolbar.

The Edit Mode toolbar has four tabs:
· Normal: Choose this editing mode to see how the document will look online

while you are creating it. Choose this mode to show table borders and named
anchor icons. All other HTML tag icons are hidden.

· Show All Tags: Choose this mode to show all HTML tag icons.

· <HTML> Source: Choose this mode to view and edit the document as
unformatted HTML source code. When you save the document, the Normal mode
reappears.
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· Preview: Choose this mode to display and edit the document exactly as it would
appear in a browser window, except that links and JavaScript functions will not
be active.

Note: JavaScript functions, frames, links, Java, embedded objects and animated GIF
files are not active in any of the editing modes. To display these items in their active
state, click the Browse button on the Composition toolbar to load the page into a

browser window.

4.13 Using Status Bar for Formatting Your Web Page

MyFreeWebsiteBuilder has an innovative feature of editing/applying inline styles and
applying class or id tags to selected text via its status bar. Styling using the status bar

is possible in all modes except <HTML> Source viewing mode.

· Select  Clicking on "Select" will select the entire text bounded by the style tag.
· Remove Tag Clicking on "Remove Tag" will remove the style tag, and in turn all

the styles for that tag will be removed.
· Change Tag Using this option, the user can change the tag used for the text

with the least effort. Clicking on "Change Tag" makes the text for the
corresponding tag to be editable in the status bar. Type in the desired tag and
press "Enter". The default properties of the tag will be applied to the text in the

web page.
· Inline StylesWhile in any of the Normal, HTML Tags, or Preview viewing modes

the tags surrounding the current position of the cursor are shown in the status
bar of MyFreeWebsiteBuilder's window. Style properties of any of the tags can be

changed by choosing an option from the context menu. To change inline style
properties:

1. Right click on the tag you wish to edit.
2. Click on "Inline Styles"

3. Select the properties section you want to edit:
§ Text Properties
§ Border Properties

§ Background Properties
§ Box Properties

§ Aural Properties
§ Extract and create Generic Style

Secting any of the options except the last one will open the corresponding tab
section from CaScadeS CSS editor (more about CaScadeS in Using Style Sheets
section). With the corresponding section open, the user can define his/her own

styles which will be saved according to W3C CSS coding style.

The Extract and create Generic Style option allows the user to extract the
style information into an style rule and save it in the external/internal style
sheet.

· Templates  offers you two options, "Make Editable" and "Remove Editable Area",
which can be used while working with Templates. For more information on
Templates, see section Working With Templates .

· ID shows ID tags(if available) from the current style sheet applied to the
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document. To apply a particular tag to the selected text, just click on that ID tag.
· Class shows the class tags(if available) from the current style sheet applied to

the document. To apply a class to the selected text just click on that Class tag.
· Advanced Properties  allows you to use the Advanced Property editor for adding

HTML attributes and Javascript to objects such as tables, images, links, etc. See
the section, Advanced Property Editor, for details.
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5 Using Style Sheets for Your Web Pages

5.1 Using Cascade Style Sheets

Cascade Style Sheets(CSS) can be used to style an HTML document in three ways:

1. Using inline styles.
2. Using internal style sheet.

3. Using external style sheets.

MyFreeWebsiteBuilder has an inbuilt style sheet editor called CaScadeS . CaScadeS can
be used to produce either an internal style sheet or an external one. As opposed to

inline styles, internal or external style sheets help to keep the content and style
information separate.

To style the html document you are editing, CaScadeS can be started by clicking on

Tools and choosing CSS Editor. CaScadeS allows two modes of style sheet editing:

1. Beginner Mode: This mode allows to create rules associated to class selectors
or type element selectors.

2. Expert Mode: This mode allows to create rules without any restriction.

In case there is no style sheet, a new style sheet will be automatically created.

5.2 Creating Style Sheets with MyFreeWebsiteBuilder

Using CaScadeS, one can create either internal style sheets or external style sheets. To

create an internal style sheet:

1. Click on the Style elt. button
o (Optional) Fill in Media list and Title information for the style sheet.

2. Click on Create Stylesheet.

To create an external stylesheet:

1. Click on the Link elt. button
2. Fill in the URL of the stylesheet in the right pane. A new file will be created on

the local filesystem, if it doesnot already exist.
o (Optional) Fill in Media list and Title informationfor the style sheet.

3. Check the "check to create alternate stylesheet" if this is an alternate one.

Tip: Always save the html document before attaching local style sheet. Also, save
document immediately before closing the CSS editor.

Tip: Use Refresh button in the left pane, if stylesheet is not immediately downloaded.
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5.3 Creating Rules for Stylesheets

After creating one or more stylesheets for the html document, rules can be created for

each stylesheet individually. To use a particular stylesheet for creating or modifying
rules, highlight the stylesheet in the left pane by clicking with left mouse button. The
right pane will show the detials of the stylesheet in the General Tab. To create new
rules:

1. Click on the Rule button in the left pane.
2. Right pane shows options as to what kind of rule to create. Choose one of:

o named style (enter class name below)

o style applied to all elements of type (enter type below)

o style applied to all elements matching the following selector

3. Fill in the name of the rule.
4. Click on Create Style Rule button.

Rules can be defined using the styling tabs (Text, Background, Border, Box and Aural)
in the right pane. To see all the definitions of a style rule, highlight the rule in the left
pane and click on "General" tab in the right pane. The "General" tab shows all
definitions currently applied to the rule.
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6 Adding Tables to Your Web Page

6.1 Inserting a Table

Tables are useful for organizing text, pictures, and data into formatted rows and
columns. To insert a table:

1. Click to place the insertion point where you want the table to appear.

     2. Click the Table button 
 

on the Composition toolbar. The Insert Table dialog box

appears.
3. Type the number of rows and columns you want.

o (Optional) Enter a size for the table width, and select either percentage of

the window or pixels.

4. Enter a number for the border thickness (in pixels); enter zero for no border.

Note: MyFreeWebsiteBuilder uses a red dotted line to indicate tables with a zero
border; the dotted line disappears when the page is viewed in a browser.

5. To apply additional table attributes or JavaScript, click Advanced Edit to display
the Advanced Property Editor .

6. Click OK to confirm your settings and view your new table.

To change additional properties for your new table, see Changing a Table's Properties.
Tip: To insert a table within a table, open the Insert menu and choose Table.

6.2 Changing a Table's Properties

This section describes how to modify properties that apply to an entire table as well as

the rows, columns, or individual cells within a table. If you are not currently viewing the
Table Properties dialog box, follow these steps:

1. Select the table, or click anywhere inside it.

2. Click the Table button 
 

on the toolbar, or open the Table menu and choose
Table Properties. The Table Properties dialog box contains two tabs: Table and Cells.

3. Click the Table tab to edit these properties:
o Size: Use this to specify the number of rows and columns. Enter the

width of the table and then choose "% of window" or "pixels." If you

specify width as a percentage, the table's width changes whenever the
MyFreeWebsiteBuilder window's or browser window's width changes.

o Borders and Spacing: Use this to specify, in pixels, the border line

width, the space between cells, and the cell padding (the space between

the contents of the cell and its border).
Note: MyFreeWebsiteBuilder uses a dotted outline to display tables with a
zero border; the dotted line disappears when the page is viewed in a
browser.

o Table Alignment: Use this to align the table within the page. Choose an

option from the drop-down list.
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o Caption: Choose the caption placement from the drop-down list.

o Background Color: Use this to choose a color for the table background,

or leave it as transparent.

4. To apply additional attributes or JavaScript events, click Advanced Edit to display
the Advanced Property Editor .

5. Click Apply to preview your changes without closing the dialog box, or click OK to
confirm them.

To view, change, or add properties for one or more cells:

1. Select the row, column, or cell, then open the Table menu and choose Table
Properties. The Table Properties dialog box appears.

2. Click the Cells tab to edit the following properties:
o Selection: Choose Cell, Row, or Column from the drop-down list. Click

Previous or Next to move through rows, columns, or cells.
o Size: Type a number for Height and Width, and then choose "% of table"

or "pixels."
o Content Alignment: Select a vertical and horizontal alignment type for

the text or data inside each cell.
o Cell Style: Select Header from the drop-down list for column or row

headers (which centers and bolds the text in the cell); otherwise choose

Normal.
o Text Wrap : Select "Don't wrap" from the drop-down list to keep text

from wrapping to the next line unless you insert a paragraph break.
Otherwise, choose Wrap.

o Background Color: Select a color for the cell background or leave it as

transparent.
Note: To apply additional attributes or JavaScript events, click Advanced
Edit to display the Advanced Property Editor

3. Click Apply to preview your changes without closing the dialog box, or click OK to

confirm them.

Tip: To change the text color or background color of one or more selected cells or the
entire table, select the cells or click anywhere in the table and then click the text color

or background color icon in the Format toolbar.

Tip: To change the color of cells to the color last used, select the cell, then press Shift
and click on the background color picker. This is useful when you want to use one color

for individual cells.

6.3 Adding and Deleting Rows, Columns, and Cells

MyFreeWebsiteBuilder allows you to quickly add or delete one or more cells, columns, or
rows in a table. In addition, you can set options that allow you to maintain the original
rectangular structure or layout of the table while you perform editing tasks.

To add a cell, row, or column to your table:

1. Click inside the table where you want to add a cell (or cells).

2. Open the Table menu and then choose Insert.
3. Choose one of the cell groupings. (You can also insert a new table within a table
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cell.)

To delete a cell, row, or column:

1. Click a row, column, or cell to place the insertion point. Or, select neighboring
cells to delete more than one row at a time. To select neighboring cells, drag
over the cells you want to select. To select individual cells in a table, hold down

the Ctrl key (Windows, Linux or Unix) or the Command key (Mac OS) and click
on the cells you want to select.

2. Open the Table menu and choose Delete.
3. Choose the item you want to delete.

To join (or merge) a cell with the cell on its right:

· Click inside the cell on the left, open the Table menu, and choose Join with Cell
to the Right.

To join (or merge) adjacent cells:

· Select adjacent cells by dragging over them.
· Open the Table menu, and choose Join Selected Cells.

To split a joined cell back into two or more cells:

· Click inside the joined cell, open the Table menu, and then choose Split Cell.

MyFreeWebsiteBuilder puts the entire contents of the joined cell into the first of
the two cells.

Refer to Selecting Table Elements  for information on how to select non-adjacent cells,

rows, and columns.

6.4 Changing the Default Table Editing Behavior

By default, when you delete one or more cells, MyFreeWebsiteBuilder preserves the

table's structure by adding cells at the end of a row, wherever needed. This allows you
to delete one or more cells but still maintain the table's original rectangular layout, or
structure. Otherwise, deleting cells can result in a table with empty spaces, or whose
outline appears irregular due to an uneven number of cells.

To change the default table editing behavior, begin from the MyFreeWebsiteBuilder
window:

1. Open the Edit menu (Mozilla menu on Mac OS X), choose Preferences, and then
choose MyFreeWebsiteBuilder.

2. Under Table Editing, set the following preference:
o Make sure that "Maintain table layout when inserting or deleting cells" is

checked to ensure that you don't get an irregularly shaped table.

3. Click OK.
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6.5 Selecting Table Elements

You can use one of two ways to quickly select a table, cell, or group of cells:

· Click in the table, open the Table menu, choose Select, and then choose an item
from the submenu. For example, to select a table, click anywhere inside the
table, open the Table menu, choose Select, and then choose Table.

· Or, you can use the mouse as a selection tool:

·
o To select a group of adjacent cells: click in a cell, and then drag to select

the cells you want. Drag the mouse left or right to select a row; up or
down to select a column.

o To select non-adjacent cells: press Ctrl (Windows, Linux or Unix) or

Command (Mac OS) and then click inside a cell. Keep pressing Ctrl
(Windows, Linux or Unix) or Command (Mac OS) as you click to select
additional cells.

o To extend a selection to include adjacent cells: click inside a cell and then

drag over additional cells to extend the selection.
o To select one or more adjacent columns or rows: drag up or down to

select the first column or row, and then drag left or right to select
additional adjacent columns or rows. Press Shift and drag to the right to

select an entire row. Press Shift and drag up or down to select an entire
column.

6.6 Moving, Copying, and Deleting Tables

To move a table:

1. Click inside the table.
2. Open the Table menu, choose Select, and then choose Table.

· To copy or move the table: Use the Edit menu's cut, copy, and paste options.

· To delete the table: Open the Table menu again, choose Delete, and then choose
Table.

6.7 Converting Text into a Table

To convert text into a table:

1. Select the text that you want to convert into a table. Keep in mind that
MyFreeWebsiteBuilder creates a new table row for each paragraph in the
selection.

2. Open the Table menu and choose Create Table from Selection. You see the
Convert to Table dialog box.

3. Choose the character MyFreeWebsiteBuilder uses to separate the selection into
columns, or specify a different character to use. If you choose Space as the

separator for columns, choose whether or not you want MyFreeWebsiteBuilder to
ignore multiple space and treat them as one space.
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4. Leave "Delete separator character" checked to have MyFreeWebsiteBuilder
remove the separator character when it converts the text into a table. If you
don't want MyFreeWebsiteBuilder to delete the separator character, uncheck this

option.
5. Click OK.

Note: Text formatting is removed when the selected text is converted to a table.
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7 Adding Pictures (Images) to Your Web Page

7.1 Inserting an Image into Your Page

You can insert GIF, JPEG, BMP, and PNG (Portable Network Graphics) images into your
web page. You can also use them to create links. When you insert an image,
MyFreeWebsiteBuilder saves a reference to the image in your page.

Note: If you plan to publish your pages to the web, it's best not to use BMP images in
your pages.

Tip: It's best to first save or publish your page before you insert images into it. This

allows MyFreeWebsiteBuilder to automatically use relative references to images once
you insert them.

To insert an image:

1. Click to place the insertion point where you want the image to appear.

2. Click the Image button 
 

on the toolbar, or open the Insert menu and choose
Image. You see the Image Properties dialog box.

3. Type the location and filename of the image file, or click Choose File to search for

an image file on your hard drive or network.
4. Type a simple description of your image as the alternate text that will appear in

text-only browsers (as well as other browsers) when an image is loading or when
image loading is disabled.

Alternatively, you can choose not to include alternate text.
5. If needed, click other tabs so you can adjust the settings (for example,

alignment) in the Image Properties  dialog box.

Tip: To quickly insert an image: Drag and drop it onto your page.

Tip: To insert a line break after all images in a paragraph, choose Break Below Images
from the Insert menu.

7.2 Editing Image Properties

Once you've inserted an image into your page, you can edit its properties and customize
the layout in your page, such as the height, width, spacing, and text alignment. If you
are not currently viewing the Image Properties dialog box, follow these steps:

To edit the properties for a selected image:

1. Double-click the image, or select it and click the Image button 
 

on the toolbar
to display the Image Properties dialog box.

2. Click the Location tab to edit these properties:
o Image Location: Type the filename and location of the image file. Click

Choose File to search for an image file on your hard drive or network.
o URL is relative to page location: If checked, MyFreeWebsiteBuilder

converts the URL to be relative to the page's location. This is especially
useful if you plan to publish your pages on a web server so that others
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can view them. Using relative URLs allows you to keep all your linked files
in the same place relative to each other, regardless of their location on
your hard disk or a web server.

Unchecking this box causes MyFreeWebsiteBuilder to convert the URL to a
full (absolute) URL. You typically use absolute URLs when linking to
images on other web servers (not stored locally on your hard disk).
If you have never saved or published the page, you must first save the

page in order to enable this checkbox. (This checkbox is not available if
you open the Image Properties dialog box in a message compose
window.)

o Alternate Text: Enter text that will display in place of the original image;

for example, a caption or a brief description of the image. It's a good
practice to specify alternate text for readers who use text-only web
browsers or who have image loading turned off.

o Don't use alternate text: Choose this option if the image does not

require alternate text or if you don't want to include it.

3. Click the Dimensions tab to edit these properties:
o Actual Size: Select this option to undo any changes you've made to the

dimensions and return the image to its original size.
o Custom Size: Select this option and specify the new height and width, in

pixels or as a percentage. This setting doesn't affect the original image

file, just the image inserted in your page.
o Constrain: If you change the image size, it's a good idea to select this in

order to maintain the image's aspect ratio (so that it doesn't appear
distorted). If you choose this option, then you only need to change the

height or width, but not both.
4. Click the Appearance Tab to edit these properties:

o Spacing: Specify the amount of space surrounding the image; between

the image and adjoining text. You can also put a solid black border around
the image and specify its width in pixels. Specify zero for no border.

o Align Text to Image: If you've placed your image next to any text,

select an alignment icon to indicate how you want text positioned relative
to the image.

o Image Map: Click Remove to remove any image map settings.

5. Click the Link tab to edit these properties:
o Enter a web page location: If you want to define a link for this image,

enter the URL of a remote or local page, or select a named anchor or
heading from the drop-down list. Click Choose File to search for an image
file on your hard drive or network.

o URL is relative to page location: If checked, MyFreeWebsiteBuilder

converts the URL to be relative to the page's location. This is especially
useful if you plan to publish your pages to a web server so that others can
view them. Using relative URLs allows you to keep all your linked files in

the same place relative to each other, regardless of their location on your
hard disk or a web server.
Unchecking this box causes MyFreeWebsiteBuilder to convert the URL to a
full (absolute) URL. You typically use absolute URLs when linking to

images on other web servers (not stored locally on your hard disk).
If you have unsaved changes, you must first save the page in order to
enable this checkbox. (This checkbox is not available if you open the
Image Properties dialog box in a message compose window.)
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o Show border around linked image: If checked, displays the link

highlight color around the image.
6. To apply additional attributes or JavaScript events, click Advanced Edit to display

the Advanced Property Editor .
7. Click OK to confirm your changes.
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8 Working with Table of Contents on Your Web Page

8.1 Adding Table of Contents to Your Web Page

For an html document having different sections, e.g. an article with sections and
subsections and headings for each section and subsection, it becomes difficult to
navigate if all the text is in a single file. To enable easy navigation of different sections,
a Table of Contents (TOC) can be generated easily with MyFreeWebsiteBuilder. To

generate a TOC for an html document:

1. Use the html heading tags (h1, h2, h3, h4, h5, and h6) to label different levels of
sections and subsections in the document. And save the document.

2. Click on Insert > Table of Contents and choose "Insert". The TOC window will
appear.

3. Select the levels of headings used for differet sections and subsections in the
document.

4. Click "OK" to build the TOC.

The TOC generated by default shows all entries as numbered and they are anchored
links to respective sections. Unchecking the "Number all entries in table of contents"

checkbox results in bulleted section entries. And checking "Make the table of contents
read only" results in sections being simple text without anchors.

8.2 Updating or Removing Table of Contents

In case the document is changed to add more sections or subsections after building the
TOC, it will not contain the new sections or subsections. To add the newly added
sections and subsections, click on "Insert", then "Table of Contents" and choose

"Update". The TOC will be updated to show the new entries.

To remove the TOC altogether, click on "Insert", then "Table of Contents" and choose
"Remove". The TOC will be removed the html source will be cleaned automatically of

any code added when TOC built.
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9 Working With Templates

9.1 Creating a Template

1. To create a template:
o Click on File > New, or click on the arrow besides "New" button and select

"More Options"
o Select Blank Template  and click on "Create

2. Add and format the content which will remain the same in every page with same
methods used to edit normal text in a web page.

3. For the content which will be different in the web pages, Editable Area can be
inserted by clicking on Insert > Templates > Editable Area. Options available for

an editable area are:
o Area is Optional

o Area is Repeatable

o Area is Movable

4. Save the file as an .mzt Template file.

Tip: You can Remove an editable area or make an area editable using the status bar.
For details refer Using Status Bar for Formatting Your Web Page.

9.2 Using a Template

To use a Template for authoring web pages:

1. Click on File > Open or use keyboard shortcut "Ctrl+N"
2. Select the option "A New Document based on a Template" and choose the

template to use by clicking on "Choose File"

3. Click on Create
4. Edit the content in the editable areas.
5. Save the file as an html document.

Tip: Click on Edit > Detach From Template to detach a document from its template.

Tip: Transformation of existing document into a template and vice-versa can be
achieved by checking(unchecking) the "Templates" option in Format > Page Title and
Properties.
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10 Setting Page Properties

10.1 Setting Page Properties and Meta Tags

Use the Page Properties dialog box to enter properties such as the title, author, and
description of the document you're currently working on. This information is useful if
you plan to use the page on a web site, since search engines use this type of
information to index your page. You can view this information from the browser window

by opening the View menu and choosing Page Info.

1. Open the Format menu and choose Page Title and Properties.
2. Edit any of the following properties:

3.
o Title: Type the text you want to appear as the window title when

someone views the page through a browser. This is how most web search
tools locate web pages, so choose a title that conveys what your page is

about.
o Author: Type the name of the person who created the document. This

information is helpful to readers who locate the document by using a web
search tool to search on name.
Tip: If you enter the Author name in MyFreeWebsiteBuilder's preferences ,

then you won't have to enter it each time you create a new page.
o Description : Enter a brief description of the document's contents.

10.2 Setting Page Colors and Backgrounds

You can change the background color or specify a background image for the page you're

currently working on. These choices affect the way text and links in your page appear to
people viewing the page through a browser.

To set the colors and background for the current page, begin from the

MyFreeWebsiteBuilder window:

1. Open the Format menu and choose Page Colors and Background.
2. Edit any of the following properties:

3.

o Reader's default colors : Select this if you want your page to use the

color settings from the viewer's browser for text and links.
o Use custom colors: Select this if you want to specify the colors of text

and links. For each element, select a color from the drop-down list.

Sample output for each type of link appears in the pane on the right.
o Background image: Select this if you want the background of your page

to be an image. Type the name of the image file or click Choose File to
locate the image file on your hard drive or network.
Note: Background images are tiled and override background color

selections.
o URL is relative to page location: If checked, MyFreeWebsiteBuilder

converts the URL to be relative to the page's location. This is especially
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useful if you plan to publish your pages on a web server so that others
can view them.
Using relative URLs allows you to keep all your linked files in the same

place relative to each other, regardless of their location on your hard disk
or a web server.
Deselecting this option causes MyFreeWebsiteBuilder to convert the URL
to a full (absolute) URL. You typically use absolute URLs when linking to

images on other web servers (not stored locally on your hard disk).
If you have unsaved changes, you must first save the page in order to
enable this checkbox.

Note: To apply additional attributes or JavaScript events, click Advanced Edit to display
the Advanced Property Editor .

You can also set the default page background and colors for every new page you create
in MyFreeWebsiteBuilder.
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11 Working With MyFreeWebSiteBuilder

11.1 Creating Links in MyFreeWebsiteBuilder

Creating Links Within the Same Page

To create a link within the same page, for example a link that the reader can use to
jump from one section to another, you must create an anchor (target location), and

then create a link that points to the anchor. Anchors are also called named anchors.

1. Click to place the insertion point at the beginning of a line where you want to
create an anchor, or select some text.

     2. Click on anchor button 
 

or open the Insert menu and choose Named Anchor.
You see the Named Anchor Properties dialog box.

3. Type a unique name for the anchor in the Anchor Name field (up to 30
characters). If you include spaces, they will be converted to underscores ( _ ). If

you selected some text in step 1, this box already contains a name.
     4. Click OK. An anchor icon appears in your document to mark the anchor's
location:  

To create the link on which readers can click to jump to the anchor:

1. Select the text or image that you want to link to the anchor.

2. Click the Link button or open the Insert menu and choose Link. You see the Link
Properties dialog box.

o If you're creating a link to an HTML file on your computer, click Choose

File to locate it.

o If you're creating a link to a named anchor (target), select it from the list

of the anchors currently available in the page.
o If you're creating a link to a level heading (for example, Heading 1 -

Heading 6), select it from the list of headings currently available in the
page.

3. Click OK.

Note: To test the link you just created, open the File menu and choose Browse Page,
then click the link.

Tip: If you did not first create named anchors, you can use the Link dialog box to create
links to headings that already occur in the page.

Creating Links to Other Pages

You can create links from your page to local pages on your own computer or on your
workplace's network, or to remote pages on the Internet.

Tip: It's best to first save or publish your page before you create links to other pages.
This allows MyFreeWebsiteBuilder to automatically use relative references for links once
you create them.

To create a link to another page:
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1. Click to place the insertion point where you want to create a link, or select the
text or image that you want to link to the anchor.

2. Click the Link button. You see the Link Properties dialog box.

3. Define your link:
o Link text: If you've already selected an image file or text before clicking

the Link button, the selected text or file will be entered here. Otherwise,
you must enter the text that you want to use as the link.

o Link Location : Type the local path and filename or remote URL of the

page you want to link to. If you're not sure of the path and filename for a
local file, click Choose File to look for it on your hard disk or network. For
remote URLs, you can copy the URL from the browser location field.
Alternatively, you can select a named anchor or a heading in the current

page that you want to link to.
o URL is relative to page location: If checked, MyFreeWebsiteBuilder

converts the URL to be relative to the page's location. This is especially
useful if you plan to publish your pages to a web server so that others can

view them. Using relative URLs allows you to keep all your linked files in
the same place relative to each other, regardless of their location on your
hard disk or a web server.
Deselecting this option causes MyFreeWebsiteBuilder to convert the URL

to a full (absolute) URL. You typically use absolute URLs when linking to
pages on other web servers (not stored locally on your hard disk).
If you have unsaved changes, you must first save the page in order to
enable this checkbox.

4. To apply additional attributes or JavaScript events, click Advanced Edit to display

the Advanced Property Editor .
5. Click OK.
6. To test the link you just created, click the Browse button and then click the link

to make sure it works as expected.

Tip: You can copy a link quickly by clicking and dragging the link from another window
and then dropping it onto your page. For example, you can click and drag a link from a
web page, bookmark, or Mail window and drop it onto your page. You can also right-

click (Control+click on Mac OS) a link on a web page and choose Copy Link Location
from the menu. Then you can paste the link location into the Link Location field in the
Link Properties dialog box.

Adding XFN Information Within Your Links

While creating links on your web page to other people's web pages,
MyFreeWebsiteBuilder provides the feature of including XFN (XHTML Friends Network)
information. The XFN is a simple way to represent human relationships using

hyperlinks. To add XFN information:

1. Right click on the link in which you want to add the XFN information.
2. Select "Link Properties".

3. In the "Link Properties" dialog window, click on "More Properties".
4. Select the corresponding entries under "Friendship" section to be added as XFN

information.
5. Click on "OK".
6. Click on "Save" to save changes/addition in document.
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Note: Some XFN properties are radio-button type i.e. pick at most one, others are
check boxes i.e. pick as many.

Using Images as Links

You can make images, such as JPEG, GIF, or PNG files, behave like links in your pages.
When the reader clicks a linked image, the browser window displays the page that the

image is linked to.

1. Select an image on your page.

     2. Click the Link button 
 

on the toolbar, or open the Insert menu and choose
Link.

3. Use the Link Properties dialog box to link the image to a named anchor or
heading within the page, or to a separate local or remote page.

Tip: Drag and drop a linked image from the Navigator window into a

MyFreeWebsiteBuilder window to copy both the image and the link.

Note: To remove the blue border on images used as links, open the Link Properties
dialog box, click the Link tab, and uncheck "Show border around linked image".

Removing or Discontinuing Links

To remove a link:

1. Select the linked text (normally blue and underlined) or image.
2. Open the Format menu and choose Remove Links.

To discontinue a link, so that text you type after the link is not included as part of the

link:

1. Click to place the insertion point where you want the link to end.
2. Open the Format menu and choose Discontinue Link.

11.2 Publishing Web Pages with MyFreeWebsiteBuilder

If your pages exist only on your local hard disk, you can privately view your HTML
pages. MyFreeWebsiteBuilder lets you publish your pages to a remote computer called a
web server.

When you publish your pages to a web server, MyFreeWebsiteBuilder copies (uploads)
your pages to a computer that lets others browse your pages. Most ISPs provide space
on their web servers for web page publishing. To find a web server where you can

publish your pages, ask your ISP, help desk, or system administrator.

Publishing a Document

To publish a document:

1. Open the HTML document that you want to publish, or create a new
MyFreeWebsiteBuilder document.
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2. When you're ready to publish the document remotely, click the Publish button
 

.
If you have published this document before, MyFreeWebsiteBuilder remembers

the document's publishing settings and starts publishing the document. While
publishing is in progress, MyFreeWebsiteBuilder displays a publishing status
dialog box.

o If you have never published this document before, MyFreeWebsiteBuilder

displays the Settings tab in the Publish Page dialog box so you can enter
information about the document's remote publishing location. See Publish
Page - Settings for more information. When you're done entering
information, click Publish.

o If you have never saved the document, MyFreeWebsiteBuilder displays

the Publish tab in the Publish Page dialog box, so you can enter the
document's filename. See Publish Page - Publish for more information.
After entering the filename, click Publish.

3. To browse your published page, click the Browse button. Test the page's links

and make sure there are no missing images.
4. Continue editing the page as necessary. When you're ready to update the remote

page with your changes, click the Publish button.

When you publish a document for the first time, MyFreeWebsiteBuilder changes the
document's file:/// URL to an http:// URL to indicate that you are now editing the
published document. If you want to save the document locally (on your computer's hard
disk), click the Save button. You'll be prompted to choose a filename and location on
your hard disk for the document.

Tips for Avoiding Broken Links or Missing Images

· Make sure your MyFreeWebsiteBuilder filenames end with the .html or .htm file

extension. Make sure your image filenames end with the .JPG, .GIF, or .PNG file
extension. Don't use spaces or other special symbols in your filenames. Keep
your filenames short and only use lowercase or uppercase letters and numbers.

· If your images appear as broken links when you browse a document on the web

server, you may have forgotten to include the images when you published. Open
the File menu, and choose Publish As to display the Publish Page dialog box. In
the Publish tab, make sure you check "Include images and other files" and then
click Publish.

For more troubleshooting tips, see Solving Common Publishing Problems.

Updating a Published Document

To update a published document:

1. In a MyFreeWebsiteBuilder window, open the File menu, and choose Recent
Pages, then select the document from the list.

Alternatively, browse to the location of the document you want to update by
entering the document's HTTP address (the document's web address) in the
Navigator browser's Location field.

2. Open the File menu, and choose Edit Page.
3. Edit the document as necessary.
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4. When you're ready to update the remote page with your changes, click Publish in
MyFreeWebsiteBuilder's toolbar.

Tip: To delete a page or image you've published on a web server, you must use an FTP
(File Transfer Protocol) program. You also must use an FTP program if you want to
create subdirectories or to rename files on the web server. Ask your service provider if
they recommend a particular FTP program. You can usually find information on FTP

programs in the Help or Support sections of your service provider's web site. FTP
programs are also available from shareware sites such as ZDNet Downloads.

Changing the Filename or Publishing Location

To change a document's filename or publishing location:

1. In a MyFreeWebsiteBuilder window, open the File menu, and choose Recent
Pages, then select the document from the list.

Alternatively, browse to the location of the document you want to update by
entering the document's HTTP address (the document's web address) in the
Navigator browser's Location field.

2. Open the File menu, and choose Edit Page.

3. Edit the document as necessary.
4. Open MyFreeWebsiteBuilder's File menu and choose Publish As.

MyFreeWebsiteBuilder displays the Publish tab in the Publish Page dialog box.
5. Enter a different page title, if necessary.

6. Enter a different filename for the page, if necessary.
7. From the Site Name list, choose the publishing location you want to use. To set

up a new publishing location, click New Site. See Publish Page - Settings for
more information.

8. Click Publish to save the document to the new location.

Creating a New Publishing Site

If you plan to publish documents to more than one remote location, you can set up

MyFreeWebsiteBuilder to save the publishing information for each remote site you use,
so that you don't have to enter it each time you want to publish.

To create a new publishing site, begin from a MyFreeWebsiteBuilder window:

1. Open the Edit menu and choose Publishing Site Settings. MyFreeWebsiteBuilder
displays the Publish Settings dialog box.

2. Click New Site.

3. For "Site Name," enter the nickname by which you want to refer to this
publishing site.
For example, if you will use the new site to publish documents related to the
"Meteor" project, you might want to use the site name "Meteor". Site names
remind you about the types of documents you publish at each site.

4. For "Publishing address," enter the complete URL provided to you by your ISP,
system administrator, or web hosting service. This URL must begin with either
ftp:// or http://.
The publishing address specifies the location where documents are published

(uploaded) at this site. If you are not sure what to enter, ask your ISP or system
administrator.
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5. For "HTTP address of your home page," enter the complete URL that you would
enter in the Navigator browser to view pages at this site. Do not include a
filename or subdirectory as part of the URL.

This URL must always begin with http://. In some cases, this URL is the same as
the publishing address. If you are not sure what to enter, ask your ISP or system
administrator, or else leave it blank.

6. For user name, enter the user name you use to log in to your ISP or web hosting

service.
7. For password, enter the password for your user name.
8. Select "Save Password" to save your password securely using Password Manager

so that you don't have to enter it each time you publish pages at this site.

9. Click OK.

Changing the Default Publishing Site

If you have set up more than one publishing site, but you typically use only one site for

most of your publishing needs, you can designate the site you use most often as the
default publishing site. MyFreeWebsiteBuilder will use the default publishing site for all
documents that you publish, unless you specifically choose an alternate site.

Regardless of how many sites you've set up, you can always publish a document to a
different site by choosing Publish As from MyFreeWebsiteBuilder's File menu. See
Changing the Filename or Publishing Location  for more information.

To choose the default publishing site, begin from a MyFreeWebsiteBuilder window:

1. Open the Edit menu, and choose Publishing Site Settings. MyFreeWebsiteBuilder
displays the Publish Settings dialog box.

2. Select a publishing site from the list.

If you only have one publishing site set up, MyFreeWebsiteBuilder uses that one
as the default site.

3. Click Set as Default.
4. Click OK to confirm your changes.

Deleting a Publishing Site

Deleting a publishing site removes the site's settings from MyFreeWebsiteBuilder. If you

later wish to publish to the site, you must re-enter the site's settings.

To delete a publishing site's settings, begin from a MyFreeWebsiteBuilder window:

1. Open the Edit menu, and choose Publishing Site Settings. MyFreeWebsiteBuilder
displays the Publish Settings dialog box.

2. Select a publishing site from the list.
3. Click Remove Site.

MyFreeWebsiteBuilder only removes the site's settings; the remote site itself is

not affected.
4. Click OK to confirm your changes.

Publishing Settings

This section describes MyFreeWebsiteBuilder's publishing settings. For information on
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MyFreeWebsiteBuilder's general and new page settings, see MyFreeWebsiteBuilder
Preferences.

Publish Page - Publish

The Publish Page - Publish tab lets you specify where you want to publish a document.
These settings apply to the current document.

If you are not already viewing the Publish Page - Publish tab, follow these steps:

1. Open the File menu and choose Publish As. The Publish Page dialog box appears.
2. Click the Publish tab.
· Site Name: Lists all the publishing sites you've created, so you can choose the

site that you want to publish to. To create a new site, click New Site.
· Page Title: Specifies the document's page title as it appears in the browser

window's title bar when you view the page in the browser. The document's page
title also appears in your list of bookmarks if you bookmark the page.

· Filename: Specifies the document's filename. Make sure you include the .html

or .htm extension in the filename.
· Warning: If a file on the remote site you're publishing to has the same filename

as one you're uploading, the newly uploaded file will replace the existing one.

You will not be asked to confirm the action.
· Site subdirectory for this page: If you leave this blank, MyFreeWebsiteBuilder

publishes the page to the main (root) publishing directory at this site. If you
want to publish the page to a remote subdirectory that resides underneath the

main publishing directory at this site, enter the name of the subdirectory or
choose it from the list. MyFreeWebsiteBuilder keeps track of the locations you
type here, so you can select from a list of remote locations you've previously
used. Keep in mind that subdirectory names are case-sensitive.

· Note: The site subdirectory you choose must already exist at the remote server.
· Include images and other files: If checked, MyFreeWebsiteBuilder publishes

any images and other files referenced by this page. You can choose to publish
these files to the same location as the page, or else you can choose to publish
these files into a remote subdirectory that exists underneath the main publishing

directory.

Tip: To create remote subdirectories or delete published pages or images, you must use
an FTP (File Transfer Protocol) program. Ask your service provider if they recommend a

particular FTP program. You can usually find information on FTP programs in the Help or
Support sections of your service provider's web site. FTP programs are also available
from shareware sites such as ZDNet Downloads.

Publish Page - Settings

The Publish Page - Settings tab lets you specify your login information for the remote
publishing site, as well as the publishing settings for the remote site. These settings
apply to the current document and any other files you publish to this location.

If you are not already viewing the Publish Page - Settings tab, follow these steps:

1. Open the File menu and choose Publish As. The Publish Page dialog box appears.

2. Click the Settings tab.
· Site Name: Specifies the nickname you want to use for this publishing site.
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Enter a short name that will help you identify this publishing site.
· Publishing address: Specifies the complete URL provided to you by your ISP or

system administrator. This URL should begin with either ftp:// or http://. This

name is often referred to as the "host name" or the "host server name".
· The publishing address specifies the location where documents are published

(uploaded) at this site. If you are not sure what to enter, ask your ISP or system
administrator.

· HTTP address of your home page: Specifies the complete address of your

publishing home directory. This is the web address of the home page at your web
site. Do not include a filename or subdirectory as part of the URL.

· This URL must always begin with http://. In some cases, this URL is the same as

the publishing address. If you are not sure what to enter, ask your ISP or system
administrator, or else leave it blank.

· User name: Specifies the user name you use to log into your ISP or network.
· Password: Specifies the password for your user name.
· Save Password : Select this to encrypt and save your password securely using

Password Manager so that you don't have to enter it each time you publish pages
at this site.

Publish Settings

The Publish Settings dialog box lets you create, edit, and delete publishing site settings,
and also lets you set the default publishing site.

If you are not already viewing the Publish Settings dialog box, follow these steps:

1. Open the Edit menu and choose Publishing Site Settings. MyFreeWebsiteBuilder
displays the Publish Settings dialog box.

· New Site: Lets you specify settings for a new publishing site.

MyFreeWebsiteBuilder adds the name of the new publishing site to the list of
available publishing sites.

· Set as Default: Sets the selected publishing site as the default publishing site.
Typically, the default publishing site is the remote location that you most often

use for publishing documents. All documents you create or edit will be published
to the default publishing site, unless you specifically choose an alternate site in
the Publish Page dialog box.

· To publish a document to a different remote location, open the File menu and

choose Publish As to choose a different publishing destination.
· Remove Site: Removes the selected site and its settings from

MyFreeWebsiteBuilder.
· Site Name: Specifies the name by which you want to refer to this publishing

site.
· Publishing address: Specifies the complete URL provided to you by your ISP or

system administrator. This URL should begin with either ftp:// or http://.
· The publishing address specifies the location where documents are published

(uploaded) at this site. If you are not sure what to enter, ask your ISP or system

administrator.
· HTTP address of your homepage: Specifies the HTTP address of your

publishing home directory. Do not include a filename or subdirectory as part of
the URL.

· This URL must always begin with http://. In some cases, this URL is the same as

the publishing address. If you are not sure what to enter, ask your ISP or system
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administrator, or else leave it blank.
· User name: Specifies the user name you use to log in to your ISP or network.
· Password: Specifies the password for your user name.
· Save Password : Select this to save your password securely using Password

Manager so you don't have to enter it each time you publish pages at this site.

Solving Common Publishing Problems

If any of your files fails to publish, the Publishing Status dialog box displays an error
message that can help you determine what went wrong and how to fix it. Click the
Troubleshooting button in the Publishing Status dialog box to get help on solving your

publishing problem.

If you are still unable to publish a file, save the file to your hard disk by opening
MyFreeWebsiteBuilder's File menu, and choosing Save. You can then open the file at a
later time to try to publish it. To quickly locate the file later, open

MyFreeWebsiteBuilder's File menu, and choose Recent Pages.

Verifying Your Publishing Settings

To verify your publishing settings:

1. Close the Publishing Status dialog box, if it is open.
2. Open the Edit menu and choose Publishing Site Settings.

3. In the Publish Settings dialog box, confirm that the site settings are correct for
the site you are trying to publish to. If you're not sure, check with your ISP or
web hosting service.

4.
o Verify that you correctly entered the publishing settings. You may

have accidentally mistyped one of the settings.
o Verify that you entered the correct publishing address. Web hosting

services or ISPs may refer to the publishing address as the "server
name", the "hostname", or the "server/host". They often specify the

publishing location as ftp.myisp.com/username, where username is your
user name.
For the publishing address to be correct, you must precede the publishing
location with either ftp:// or http://. For example, the correct publishing

address for the above-mentioned site would be
ftp://ftp.myisp.com/username.

Checking Your Filenames

Examine the names of any files that failed to publish. Make sure that the filenames:

· Use only numbers or lowercase or uppercase letters. While it's acceptable to
create filenames that use uppercase letters, you can avoid potential errors in

later locating the published file if you only use lowercase letters in your
filenames.
When you publish files to a web server, filenames become case-sensitive on the
web server. It may be harder for you to remember files names that use only

uppercase letters or that use a mix of uppercase and lowercase letters.
For example, when you try to locate a published file by typing the filename's web
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address into Navigator's Location field, you must enter the filename exactly as
you created it, using the same combination of uppercase and lowercase letters.

· Don't use punctuation characters or spaces. Underscores ( _ ) or hyphens ( - )

are OK.
· End with .html or .htm (for MyFreeWebsiteBuilder filenames).
· Use less than 32 characters.

Fixing Publishing Errors

If one or more of your files fails to publish, look at the messages MyFreeWebsiteBuilder
displays in the Publishing Status area of the Publishing dialog box. You can use these

error messages to help determine what went wrong and what to do to fix the problem.

Error Message:

Filename  not found

or
X of Y files failed to publish

Error Description:  One or more image files or CSS files failed to publish because

MyFreeWebsiteBuilder could not find them. Some typical reasons might be:

· The file location you typed is incorrect.
· The file's location on the web is not accessible.
· The file's location was changed or the file was deleted or moved to another

location.

Possible Solutions:

        · Look for broken images in the page you are trying to publish. Broken images will

appear with this icon  in the page. To correct the image's address, double-click the

broken image to display the Image Properties dialog box so you can enter the correct
address.

· Remove the broken image from the page by selecting it (click once on the
image), and then pressing Backspace or Delete on your keyboard.

· If the image is unavailable because the server where the image resides is

inaccessible, try publishing the page at a later time.
· If the missing file is a CSS file, you must first verify the correct location of the

CSS file. To fix the file's address in MyFreeWebsiteBuilder, click the HTML Source

tab and edit the file's location in the HTML source code. You should only edit the
HTML source if you are familiar with HTML tags.

Error Message:

The subdirectory directory name doesn't exist on this site or the filename filename  is
already in use by another subdirectory
or
The filename filename is already in use by another subdirectory

Error Description:  You specified the name of a remote subdirectory that does not exist
at the publishing site. MyFreeWebsiteBuilder can only publish to a remote subdirectory
that already exists at the publishing location. Or, you specified a filename that is
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identical to the name of an existing subdirectory at the publishing site.

For example, in the Publish Page dialog box, under the Publish tab:

· for "Site subdirectory for this page", you may have typed the name of a
subdirectory that does not exist at the publishing location.

· you checked "Include images and other files," and then you typed the name of a

subdirectory that does not exist at the publishing location.
· one of the files you are attempting to publish has the same name as a

subdirectory at the publishing site.

Possible Solutions:

· Use a separate FTP program if you want to create, rename, or delete
subdirectories at the publishing site. Ask your service provider if they
recommend a particular FTP program. You can usually find information on FTP

programs in the Help or Support sections of your service provider's web site. FTP
programs are also available from shareware sites such as ZDNet Downloads.

· Don't use subdirectory names that end with ".html" or ".htm". Only your
MyFreeWebsiteBuilder filenames should end with ".html" or ".htm".

· Subdirectory names are case-sensitive, so be sure to enter a subdirectory name

exactly as it appears at the publishing location.

Error Message:

The server is not available. Check your connection and try again later.

Error Description:  This error can have many causes. For example:

· Your publishing site settings may not be correct.

· Your Internet connection may have been lost.
· Your modem or other equipment that you use to connect to the Internet might

not be functioning correctly.
· The web server that you are trying to publish to might be unavailable due to a

technical problem or to an unknown circumstance.
· Your ISP or web hosting service may be experiencing technical problems.

Possible Solutions:

· Verify that your publishing settings are correct and that you entered them
correctly. See Verifying Your Publishing Settings for more information.

· Make sure your Internet connection is working by attempting to view a web page

using the Navigator browser. For example, confirm that you can successfully
view the page http://www.mozilla.org.

· If your Internet connection is not working, verify that all hardware, telephone
connections, modems, and network connections are functioning properly.

· Use the Navigator browser to try to view a page at the web site you are

attempting to publish to. If you can successfully view other web sites but cannot
view a page at the publishing site, your ISP or web hosting service may be
experiencing technical problems.

· Try publishing again later. Your ISP, web hosting service, or the web server may

be experiencing temporary technical difficulties.
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Error Message:

You do not have permission to publish to this location.

Error Description:  You are attempting to publish to a location that you are not
authorized to use. You can only publish to sites where you have been granted access by
your ISP or web hosting service.

Possible Solutions:

· Verify that you entered the correct user name and password in the Publishing

Site Settings dialog box, or in the Publish tab of the Publish dialog box.
· Contact your ISP to find out where you can publish your pages at their site.
· Find a web hosting service that you can use to publish your pages. In the

Navigator browser, search for "web hosting".
· Use MyFreeWebsiteBuilder My Webpage http://mywebpage.netscape.com/ to

host your web pages, up to 20 megabytes for free.

Error Message:

You are currently offline. Click the icon near the lower-right corner of any window to go
online.

Error Description:  You are attempting to publish, but your MyFreeWebsiteBuilder

Internet connection is currently in the "offline" state. Your Internet connection must be
in the "online" state (connected to the Internet) in order to publish your pages.

Verify that your Internet connection is currently offline by looking at the online/offline
icon in the lower right corner of any MyFreeWebsiteBuilder window. If you are currently

offline, the icon appears different.

Possible Solutions:

        · Click the online/offline icon to go online. In the online state, the icon should look

like this:  .
· Make sure your Internet connection is working by attempting to view a web page

using the Navigator browser. For example, confirm that you can successfully
view the page http://www.mozilla.org.

Error Message:

There is not enough disk space available to save the file filename.

Error Description:  The remote web server's hard disk is full, or you may have

exceeded the amount of disk space allocated to you by your ISP or web hosting service.

Possible Solutions:
· Use a separate FTP program to delete unnecessary files at your publishing site.

Ask your service provider if they recommend a particular FTP program. You can
usually find information on FTP programs in the Help or Support sections of your
service provider's web site. FTP programs are also available from shareware sites
such as ZDNet Downloads.
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· Find out from your ISP or web hosting service about increasing your disk space
allocation, or switch to a different service that can satisfy your needs.

· If the web server is located at your company or school, contact the network

administrator to find out if you can publish to a different location that has more
disk space, or if you can request that additional disk space be allocated to your
current publishing location.

Error Message:

The filename or subdirectory name is too long.

Error Description:  The number of characters in the filename or the subdirectory name
is not supported by the web server computer that you are trying to publish to.

Possible Solutions:

· Limit the length of your filenames and subdirectory names to less than 32

characters. Some operating systems do not support names longer than 32
characters.

11.3 MyFreeWebsiteBuilder Preferences

MyFreeWebsiteBuilder has several important settings in the Preferences panel. Users
can set the preferences depending on their requirements and MyFreeWebsiteBuilder will
respect the setting everytime the user starts and uses it.

This section describes the settings in the MyFreeWebsiteBuilder preferences panel. If
you are not currently viewing the panel, follow these steps:

1. Click on Tools > Preferences file menu (Mozilla menu on Mac OS X) items to open

Preferences(Options) panel.
2. Click the MyFreeWebsiteBuilder category to view the corresponding settings

available for customization.

For information on MyFreeWebsiteBuilder's publishing settings, see Publishing Settings

section.

General Settings

General preferences allow you to specify settings for saving files and for table editing.
These settings apply to every document you create.

If you are not already viewing the MyFreeWebsiteBuilder general preferences, follow

these steps:

1. Open the Edit menu (Mozilla menu on Mac OS X) and choose Preferences.
2. Click the General category on the category sidebar.

Recent Pages Menu

Maximum number of pages listed: Specify the maximum number of pages that are
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listed under Recent Pages in the File menu.

When Saving or Publishing Pages

· Retain original source formatting: This option preserves line breaks and the
page's original formatting for the HTML source code. Select this if you want to
preserve white space (extra lines, tabs, etc.) that makes the HTML source code

more readable. This preference does not affect how your pages appear in a
browser window.

· Reformat HTML source: This option reformats the HTML source code to make it
more readable, by inserting line breaks and indentation. This preference does not

affect how your pages appear in a browser window.
· Save images and other associated files when saving pages: If checked, all

images, JavaScript (JS), Cascading Style Sheet (CSS), and other associated files
are saved in the same location as the document when the document is saved for
the first time or when the document is saved to a new location. If unchecked,

only the HTML file is saved.
· For example, when editing a remote page, this setting ensures that all related

files associated with the remote page will be saved locally when you save the
page to your hard disk.

· Always show Publish dialog when publishing pages: If checked,

MyFreeWebsiteBuilder always displays the Publish Page dialog box when you click
the Publish button or choose Publish from the File menu. If not checked,
MyFreeWebsiteBuilder only displays the Publish Page dialog box if it needs more

information in order to publish the page.

Table Editing

Maintain table layout when inserting or deleting cells: Select this if you want

MyFreeWebsiteBuilder to always preserve the table's layout (that is, keep it in a
rectangular shape) by adding cells where needed. If you deselect this option, when you
delete one or more cells, MyFreeWebsiteBuilder removes the cell border as well, which
can result in a table with empty spaces, or an outline that appears irregular due to an

uneven number of cells.

Cascading Style Sheets(CSS) Editing

Use CSS styles instead of HTML elements and attributes: Enables the use of
Cascading Style Sheet (CSS) formatting in your MyFreeWebsiteBuilder documents. With
this preference enabled, MyFreeWebsiteBuilder generates HTML 4.01 formatting with
CSS inline styles for elements.

If this preference is not enabled, MyFreeWebsiteBuilder generates HTML 4.01
formatting, but does not use CSS styles.

Compared to HTML, HTML with CSS formatting is more portable, more maintainable,

and more compatible when viewed with different browsers. If you enable this preference
and then edit a document created without CSS, MyFreeWebsiteBuilder replaces the
edited elements with CSS styles.

If you enable CSS styles, you can choose a text highlight color for selected text using
the text highlight color button on the Format toolbar. You can also choose a color
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background for any element on the page. (These features are not available if this
preference is not enabled.)

Site Manager

Always open a document in a new tab: Select this if you want to open documents in
new tabs when using the Site Manager. If unchecked, double clicking on filenames in

the Site Manager will open the files in new windows.

Fonts

Fonts displayed in MyFreeWebsiteBuilder are either the program defaults or the user can
define their own.

Fonts for

Font family can be defined in the Fonts for: section of MyFreeWebsiteBuilder
Preferences. To change the default typeface:

1. From the Fonts for drop-down list, choose a character set. For instance, to set

default fonts for the Western (Roman) character set, choose Western .
2. Select whether proportional text should be serif (like "Times New Roman") or

sans-serif (like "Arial"). Then specify the font size you want for proportional text.
3. Specify the font to use for Serif, Sans-serif, Cursive Fantasy and Monospace font

families. You can also change the size for Monospace fonts.

You can also choose the Minimum font size you want to display. Setting a minimum font
size can be helpful when editing pages with very small fonts which would be hard to
read if this option is not set.

You can also specify the display resolution, which is normally 96 dpi. You can set it to
one of the predefined options e.g. 72dpi, or 96dpi or you can either set it to System
Setting  or set it manually using the Other...  option.

New Page Settings

New page settings allow you to specify settings for colors and background images that

apply to every document you create.
If you are not already viewing the New Page Settings, follow these steps:

1. Open the Tools menu (Mozilla menu on Mac OS X) and choose Preferences.

2. Click on the New Page Settings icon on the category sidebar

Author

Enter your name. This will add your name to the HTML source code for each new page

you create. Your name will be added in the <head> section of the web page and will not
be visible on the web page.

Markup

· Language: Users can select which language to use as default when creating new
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web documents. Choose from either HTML4.0 or XHTML1.0.
· DTD: Select the DTD to be used as default when creating new web documents.

Options of defining the document as Transitional  or Strict  are available.

Default Page Appearance

· Reader's default colors : Select this if you always want your pages to use the

color settings from the viewer's browser for text and link elements.
· Use custom colors: Select this if you always want to specify the colors that are

applied to text and link elements. Then for each element, select a color by
clicking the color button next to each element which will open the color-picker to

select the color easily.
· Background image: Type the location and name of an image file, or click

Choose File to locate the image file on your hard disk or network.
Note: Background images are tiled and override background color.

· To change the author name for an individual page: Open the Format menu and

choose Page Title and Properties.
To change the page colors and background image for an individual page: Open
the Format menu and choose Page Colors and Background.

Internationalization

· Language: Choose the language in which the html documentsupposed to be
written in.

· For example if the document is written in Canadian French, selecting

"French/Canada[fr-ca]" will indicate the browser that the document is written in
Canadian French. And the html source will contain <html lang="fr-ca"> as an
indicator of document language.

· Writing Direction: Choose the direction of writing text depending on the

language you are using in your document. This solves the problems of users
creating html pages in languages with right-to-left direction, for example, Arabic,
Urdu, etc.

· To change the Language specification for an individual page: Open the Format

menu and choose Page Title and Properties, and change language in the
Internationalization section.
To change the Writing Direction of an individual page: Open the Format menu
and choose Page Title and Properties, and change language in the

Internationalization section.
· Character Set: Character sets determine how the bytes that represent the text

of your HTML document are translated to readable characters. With this option
you can choose the character set you want to use for your web page. By default,

the ISO-8859-1  character set is used, but you can use other options like UTF-8,
ISO-8859-15 , etc or a user defined character set.

Advanced Settings

Connection

This section describes how to use the Proxies preferences panel. If you're not already
viewing it, follow these steps:

1. Open the Edit menu (MyFreeWebsiteBuilder menu on Mac OS X) and choose
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Preferences.
2. Under the Advanced category, click Proxies. (If no subcategories are visible,

double-click Advanced to expand the list.)

The Proxies preferences panel allows you to set up MyFreeWebsiteBuilder to use a
proxy:

Before you start: Ask your network administrator if you have a proxy configuration file
or for the names and port numbers of the proxy.

· Direct connection to the Internet: Choose this if you don't want to use a

proxy.
· Manual proxy configuration : Choose this if you don't have a proxy location

(URL).
o HTTP Proxy, SSL Proxy, FTP Proxy, Gopher Proxy: Type the name or

numeric IP address of the proxy server. Type the port in the Ports field.

o SOCKS Host: Type the name or numeric IP address of the proxy server.

Type the port in the Ports field.
§ SOCKS v4, SOCKS v5: When entering a SOCK Host, select

"SOCKS v4" or "SOCKS v5," depending on what version of SOCKS
is used for the proxy.

o No Proxy for: Type the domains and/or IP address that you do not want

to use a proxy for. Separate each entry with a comma. (Example:
.yourcompany.com, .yourcompany.co.nz, 192.168.1.0/24)

· Automatic proxy configuration URL: Choose this if you have a proxy

configuration file or URL, then type the configuration URL.

Return Key Behaviour

The option "Return in a paragraph always creates new paragraph" defines the behaviour
of the return key. Choosing it creates a new paragraph if you hit the "Return" key while
typing in a paragraph. Without this option <br> tags are added for carriage returns.

Real-time Spellcheck

Checking the option "Underline misspelled words" will enable the real-time spell
checker built into MyFreeWebsiteBuilder to underline misspelled words, thus giving the

user a visual clue to recheck the spellings.

Special Characters

This options allow the user to choose which special characters are coded as entities by
MyFreeWebsiteBuilder. Choose one of the option:

· Only & < > ' and non-breakable whitespace
· The above and Latin-1 letters
· All characters having an entity equivalence in the HTML 4.0 specification

· Use &#..; notation for all non-ASCII characters
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11.4 MyFreeWebsiteBuilder Menu Reference

This menu reference describes each menu item in the main MyFreeWebsiteBuilder

window.

File

New
Opens a new MyFreeWebsiteBuilder window.

Open File...
Displays an Open File dialog where you can select a file from your local disks or

network. With MyFreeWebsiteBuilder you can view HTML, HTML templates, and text file
types.

Open Web Location...

Displays an Open Web Location dialog for writing the URL of the document or choose a
local file to open.

Recent Pages

Shows the list of recently edited files.

Close
Closes the current window.

Close All
Closes all open tabs in current window.

Save

Save the file opened in the current active tab.

Save As...
Saves the page you are currently editing giving the option of saving it with a different

filename.

Save And Change Character Encoding
Gives an option of changing the "Charset" of the web page before displaying the "Save

As..." dialog.

Publish
Opens a Publish dialog for publishing the current page being edited

Publish As...
Opens a Publish dialog for publishing the current page being edited. Behaves the same
as Publish\!!

Revert
Undo all changes done to the current document after last save. Reverts to last saved
copy of current document.

Export To Text...
Export the contents of the current document to plain text.
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Browse Page
View the current page in your default web browser

Page Setup...
Opens the Page Setup options dialog for configuring printing options.

Print Preview

Opens a window showing how the document will look when printed on paper.

Print...
Displays the Print dialog, where you can select the printer, specify the number of

printed copies, etc. Click OK to print the page.

Quit
Closes all MyFreeWebsiteBuilder windows including any with more than one tab open,
and exits MyFreeWebsiteBuilder completely. If you happen to select this option with

unsaved documents, MyFreeWebsiteBuilder will ask you to confirm your choice to
prevent accidental exits.

Edit

Undo
Undoes the last editing action done in the current document. If you later decide you
didn't want to undo an action, use the Redo command.

Redo
Redoes the last Undo command.

Cut

Cuts the selected text from the document and stores it in the clipboard. Paste the text
elsewhere by using the Paste command.

Copy

Copies the selected text to the clipboard. Paste the text elsewhere by using the Paste
command.

Paste

Pastes the text from the clipboard copied using Cut or Copy command to the current
cursor location.

Paste Without Formatting

Pastes the text from the clipboard copied using Cut or Copy command to the current
cursor position as simple text i.e. formatting information of clipboard text is discarded.

Delete
Deletes the selected text from current document.

Select All
Selects all text in the current document.

Find and Replace...
Displays a dialog where you can enter a text string to be searched and replaced with
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another text string. Search is performed on the current page.

Find Again

Performs the operation of finding the text string searched with the Find and Replace...
command for next occurence of the text. Search is performed on the current page.

Find Previous

Searches for the previous occurrence of the text specified when using the Find and
Replace... command.

Check Spelling

Opens the Spell Checker to start the spell check for the text on the current page.

Detach From Template
Detaches the current document being edited from the template to be saved as an html
page.

Publish Site Settings
Opens the Site Manager to configure or change settings for the publishing site.

View

Show/Hide

Composition Toolbar
Toggles the visibility of the composition toolbar, which usually contains standard
composition buttons (Anchor, Link, Image, etc.).

Format Toolbar

Toggles the visibility of the format toolbar, which contains various formatting buttons.

Edit Mode Toolbar
Toggles the visibility of edit mode toolbar. Edit Mode Toobar is at the bottom of the

MyFreeWebsiteBuilder window just above the status bar. You can change to different
views like HTML Tags view, HTML Source view, etc with it.

Status Bar

Toggles the visibility of the Status Bar situated at the bottom of the
MyFreeWebsiteBuilder window.

Rulers

Toggles the visibility of horizontal and vertical rulers.

Customize Toolbar

Main Toolbar

Opens panel to customize Main Toolbar. You can drag and drop buttons from the panel
to the main toolbar to add new buttons or vice-versa to remove buttons.

Format Toolbar

Opens panel to customize Format Toolbar. You can drag and drop buttons from the
panel to the format toolbar to add new buttons or vice-versa to remove buttons.
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Site Manager
Toggles the visibility of Site Manager in the MyFreeWebsiteBuilder window.

Normal Edit Mode
Changes to the Normal Edit Mode viewing mode.

HTML Tags

Changes to the HTML Tags viewing mode.

HTML Source
Changes to the HTML Source viewing mode.

Preview
Changes to the Preview viewing mode.

Carriage Returns

Toggles the visibility of carriage returns.

Block Outline
Toggles the visibility of outline of block level elements on the page.

Text Zoom

Smaller

Makes the text smaller on the web page. You can also do this with the mouse (see
Increase Text Size for instructions). To restore the text size, press Ctrl+0.

Larger
Displays the text one size larger on the web page. You can also do this with the mouse

by holding down the Ctrl key while using the scroll wheel or by pressing + or - to
increase or decrease the text size. To restore the text size to the default, press Ctrl+0.

Character Encoding

Allows you to manually change the character encoding on a Web page.
MyFreeWebsiteBuilder usually does this automatically.

Insert

The Insert menu allows you to insert various HTML elements in the current document
being edited.

Image...
Opens a dialog box to insert an image in the current document.

Table...
Opens a dialog box to insert a table in the current document.

Form...

Link...

Opens a dialog box to create a link. If clicked after selecting text in current document,
the selected text will be made the link. You can also define Friendship(XFN) properties
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by clicking "More Properties" in the dialog box.

Named Anchor...

Opens a dialog for typing-in the name to insert a Named Anchor at the current position
of the cursor.

Horizontal Line

Inserts a horizontal line in the current document.

HTML...
Opens a dialog to insert HTML code manually. This can also be used to insert comments,

script code, etc.

Characters and Symbols...
Opens a dialog box to select special characters or symbols to insert in the current
document.

Table of Contents...
Opens a window to insert a Table of Contents at the current position of the cursor. The
TOC can be selected to be formed of either Heading Level-1 to Level-6, a <div> or a

<p> tag.

Smart Widgets
Inserts Smart Widgets in your document.

Made With MyFreeWebsiteBuilder button
Inserts a "Made with Nvu" button in the document.

Calendar

Inserts a calendar type object in the document.

Templates
When working with Templates, you can use this menu item to insert an editable area in

your template.

PHP Code
Insert PHP code in your HTML document.

Comment
Insert a comment in your HTML document.

Break Below Image(s)
Inserts a break below images to make the text written besides the image to appear
below it.

Format

This menu contains various options to format the document text.

Font

You can choose the font face to apply to the selected text in the current document. You
can select the desired font face from the list containing all the available fonts installed
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on your system.

Size

By selecting Smaller or Larger you can change the size of text being viewed in
MyFreeWebsiteBuilder.
Selecting x-small, small, medium, large, x-large, or xx-large changes the font size of
selected text in the current document.

Text Style
You can select the HTML Text Style which will be applied to the selected text in the
document.

Bold
Makes the selected text to appear bold. E.g. bold text

Italic

Makes the selected text to appear italicized. E.g. italic text

Underline
Underlines selected text. E.g. underlined text

Strikethrough
Applies a strikethrough on selected text. E.g. struck-through text

Superscript
Makes the selected text to appear as superscript. E.g.superscript  text.

Subscript
Makes the selected text to appear as subscript. E.g. subscript  text.

Fixed Width
Makes the text appear as fixed width. E.g. fixed width text.

Non Breaking
HTML breaks down multiple spaces to a single one. To mark non-breaking space use this
option after selecting the space in the document. E.g. 3 nonbreaking spaces   here.

Emphasis
Makes the text appear emphasized. E.g. emphasized text

Stronger Emphasis

Gives the selected text a stronger emphasis. E.g. strong emphasized text.

Citation
Defines the selected text as citation. E.g. Citation text

Abbreviation
Indicates the text is an abbreviated form. E.g. UN

Acronym

Defines the start of an acronym. E.g. WWW
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Code
Defines the selected text as computer code text. E.g. code text

Sample Output
Defines the selected text as sample computer code. E.g. sample code

Variable

Defines the selcted text as a variable. E.g. variable

Text Color...
Opens the color picker popup window to choose the color for selected text.

Writing Direction
Gives the choice of writing the text as Left-to-Right or Right-to-Left. The slected text
should be block-level and not inline text.

Discontinuing Text Styles
Discontinues the application of any text styles being used from the current position of
the cursor.

Discontinue Link
Discontinues the text to be link text from current position of cursor.

Remove Named Anchors

Removes the selected named anchor.

Paragraph
Gives the option to tag the selected text as Body Text, Paragraph, Heading Level-1 to
Level-6, Address, or preformatted text.

List
Start a list with an option for various list types, namely, Bulleted, Numbered, Term or
Definition. Choosing List Properties opens a dialog box to manually edit list properties.

Increase Indent
Increases the indent of the selected block of text.

Decrease Indent
Decreases the indent of the selected block of text.

Align

Lets you select the alignment for the selected text. You can make the text to be center
aligned, left aligned, right aligned or simply justified text.

Positioning Grid
Opens a dialog box to set the resolution in pixels for moving a layer.

Advanced Properties
Opens the "Advanced Property Editor" where you can manually edit/add HTML
attributes, Inline Styles, or even Javascript events.

Page Colors and Background...
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Opens a window to select Page Colors and Background. Users can select the color of
Normal text, Link text, and Active and Visited link text. You can also choose the
background color for your web page and optionally attach a background image to the

page too.

Page Title and Properties...
Opens up the "Page Properties" window where you can add the Title, Author, and

Description information for your web page. You can also specify the language and
writing direction you will be using in the current web page document. To use this page
as a template you can check the "This page is a template" check box.

Table

This menu enables you to create/edit tables in an HTML document.

Insert

Opens a sub menu with choices for various table editing/creating options.

Table
Opens a dialog box to choose various properties of table to be inserted at the current

location of the cursor. Users can choose the size of table by clicking on the shown table
grid or choose precise table size. Other cell properties like cellspacing, cellpadding, etc
can also be set.

Row Above
Inserts an empty row above  the currently active table row.

Row Below
Inserts an empty row below  the currently active table row.

Column Before
Inserts an empty column before the currently active table column.

Column After
Inserts an empty column after the currently active table column.

Cell Before

Inserts an empty cell before the currently active table cell.

Cell After
Inserts an empty cell after the currently active table cell.

Select
Selects various components of the currently active table for editing.

Table

Select the whole table.

Row
Select the currently active row.

Column
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Select the currently active column.

All Cells

Select all cells. This is different from selecting the whole table, as changes will be
applied individually to all cells rather than the table.

Delete

Opens submenu to delete various table components.

Table
Delete currently active table. User with caution, all table data will be lost.

Row(s)
Delete currently active row or selected rows of table.

Column(s)

Delete currently active column or selected columns of table.

Cell(s)
Delete currently active cell or selected cells of table.

Cell Contents
Delete contents of active cell.

Join With Cell to the Right
Merge current table cell with the cell immediately to its right.

Split Cell
Split a cell which has a colspan value of more than 1.

Create Table from Selection
Creates a table from the selected text. A row is created for each paragraph of selected
text. Column separations can be chosen to be either of comma (,), space ( ), or a user

defined character.

Table or Cell Background Color...
Opens a dialog box to edit table or cell background color.

Table Properties...
Opens the table and cell properties editing window. You can change all table and cell
properties using the simple GUI.

Tools

Markup Cleaner
Opens the Markup Cleaner window. Markup cleaner tidies up the html code by removing

extra <br> tags, empty blocks, etc.

Validate HTML
Opens a window to show current document's validation results as given by W3C's HTML

validator .
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CSS Editor
Opens CaScadeS the inbuilt CSS editor for editing CSS style rules.

Extensions
Opens the Extension manager which can be used to install or remove installed
extensions. Extensions adds new features to MyFreeWebsiteBuilder.

Themes
Opens the Theme Manager which can be used to install or uninstall themes for
MyFreeWebsiteBuilder.

Web Development
Opens various tools packaged with MyFreeWebsiteBuilder for web developers.

Javascript Console
Opens Javascript console window.

Java Console
Opens Java console window.

Preferences
Opens the Preferences window to change personal preferences for
MyFreeWebsiteBuilder

Help

Help Contents
Opens the Help Viewer window.
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